古早插件升级遇到问题怎么办?

Viewed 42

初始化的时候提示:

npm ERR! request to https://npm.partner.ones.ai/registry/@ones-op/node-utils/download/@ones-op/node-utils-0.3.7.tz failed, reason: Hostname/IP does not match c ertificate's altnames: Host: npm.partner.ones.ai. is not in the cert's altnames: DNS:*.partner.ones.cn
1 Answers

npm 代理相关问题

npm.partner.ones.ai 代理源早已废弃,需要改为 npm.partner.ones.cn,然后重新安装依赖

安装完后需要检查 package-lock.json 文件是否存在 npm.partner.ones.ai,如果有,可能是因为某些包依赖的版本过老,找出对应的包,到 https://npm.partner.ones.cn/ 搜索对应的包版本,逐渐往上升级,找到最低可用版本就行(版本跨度太大可能有破坏性变更)
直到确保 package-lock.json 文件不存在 npm.partner.ones.ai

ONES Design 相关包从 2024.05.07 开始迁移至 npm 官方注册表,废弃原有的 npm.partner.ones.cn 代理

使用 2024.05.07 之前发布的版本,继续使用 npm.partner.ones.cn 代理